Sensor software upgrade requirements

This section details the requirements to upgrade the Sensor software to 9.2. In this section, the term Sensor refers to NS-series and Virtual IPS Sensors unless otherwise specified.

Important: If you are using a hot-fix release, contact McAfee Support for the recommended upgrade path.

Minimum required Sensor software versions

NS-series (NS3100, NS3200, NS3500, NS5100, NS5200, NS7100, NS7200, NS7300, NS9100, NS9200, NS9300):

Component Upgrade path to 9.2
8.1.5.14, 8.1.5.39, 8.1.5.57, 8.1.5.135 8.1.5.175 | 9.2.5.10 | 9.2.5.163
8.1.5.175, 8.1.5.210, 8.1.5.215, 8.1.5.217, 8.1.5.219, 8.1.5.223 9.2.5.10 | 9.2.5.163
8.3.5.6, 8.3.5.11, 8.3.5.32, 8.3.5.47, 8.3.5.48, 8.3.5.53, 8.3.5.61 9.2.5.10 | 9.2.5.163
9.1.5.9, 9.1.5.20, 9.1.5.23, 9.1.5.40 9.2.5.10 | 9.2.5.163
9.1.5.56, 9.1.5.63, 9.1.5.80 9.2.5.163
9.2.5.6, 9.2.5.25, 9.2.5.27, 9.2.5.72, 9.2.5.153 9.2.5.163
Note: The NS-series Sensor software version 9.2.5.10 is not available in the McAfee Download Server. Contact McAfee Support, at https://support.mcafee.com for the NS-series Sensor software version 9.2.5.10.
Note: All intermediate Sensor software versions, such as Hotfixes, below 8.1.5.175 must upgrade to 8.1.5.175, and then 9.2.5.10 before upgrading to the latest 9.2 Sensor software version. If you are on Sensor software version 8.1.5.175 and above, or 8.3, first upgrade to version 9.2 5.10 before you upgrade to the latest 9.2 Sensor software version.

NS9500 Sensor:

Version Upgrade path to 9.2
9.2.5.50, 9.2.5.52 9.2.5.53 | 9.2.5.88

NS-series (NS7150, NS7250, NS7350):

Component Upgrade path to 9.2
9.1.5.15, 9.1.5.20, 9.1.5.23 9.1.5.40 | 9.2.5.163
9.1.5.40, 9.1.5.56, 9.1.5.63, 9.1.5.80 9.2.5.163
9.2.5.27, 9.2.5.72, 9.2.5.153 9.2.5.163

To enable outbound SSL decryption feature, follow the upgrade path below: (Outbound SSL decryption is supported only on standalone NS9500, NS9100, NS9200, NS7200, and NS7300 sensor models)

Note: You must first purchase a license to enable outbound SSL decryption feature. To obtain a license for outbound SSL decryption, contact MB Licensing. An email containing the license will be sent from MB Licensing. The 9.2.5.25 Sensor software version for outbound SSL decryption is available at Patches and Downloads. If you are a first time user, you must register with your email ID and Grant number to log in to the portal. In the Service Portal, click Patches and Downloads to register and log in to the portal.
Note: All intermediate Sensor software versions, such as Hotfixes, below 8.1.5.175 must upgrade to 8.1.5.175 before upgrading to the latest 9.2 Sensor software version. All Sensor software versions above 8.1.7.175 can directly upgrade to the latest 9.2 Sensor software version.

Virtual IPS Sensor software ESXi (IPS-VM600) :

Current version Upgrade path to 9.2
8.1.7.44, 8.1.7.47 9.2.7.56
8.3.7.56, 8.3.7.59 9.2.7.56
9.1.7.13, 9.1.7.18, 9.1.7.22, 9.1.7.25 9.2.7.56
9.2.7.10, 9.2.7.20, 9.2.7.26, 9.2.7.54 9.2.7.56

Virtual IPS Sensor software VMware NSX (IPS-VM600-VSS):

Current version Upgrade path to 9.2
9.2.7.12, 9.2.7.17, 9.2.7.20, 9.2.7.26 9.2.7.54

Virtual IPS Sensor software AWS (IPS-VM600-VSS):

Current version Upgrade path to 9.2
9.1.7.4 9.2.7.54
9.2.7.10, 9.2.7.20, 9.2.7.26 9.2.7.54

Note: Upgrade to Azure Virtual IPS Sensor software version 9.2.7.132 is not supported for IPS-VM600-VSS. This version of 9.2 supports only a fresh installation of the Virtual IPS Sensor.

Note: Upgrade for IPS-VM600 from Sensor software versions 8.1, 8.3, or 9.1 to Sensor software version 9.2 is not supported due to increased Sensor image size. For more information, see Upgrade consideration for Virtual Sensors deployed in ESX.

Note: All intermediate Sensor software versions for Virtual IPS, such as Hotfixes, can directly upgrade to the latest 9.2 Sensor software version.

License file requirement

Physical appliances do not need any licenses.