Supported Internet browsers

McAfee ePO software requires the use of one of these supported Internet browsers.

  • Internet Explorer 11 or later
  • Firefox 45 and later
  • Chrome 51 and later
  • Safari 10 and later (macOS only, Windows not supported)
  • Microsoft Edge

TLS requirement

If you are using an older browser, make sure that you have TLS 1.2 enabled.

Using Internet Explorer enhanced security

If you're using Internet Explorer with enhanced security enabled, add the McAfee ePO server address to your Internet Explorer trusted sites list (formatted as https://<servername>). If you don't, Internet Explorer displays an error message when you try to log on to the McAfee ePO server.