What is installed with McAfee Endpoint Security 10.7.x

McAfee Endpoint Security 10.7.x is made up of multiple product modules that are installed by default when you install the product bundle.

Endpoint Security includes these modules:

  • McAfee® Endpoint Security Threat Prevention
  • McAfee® Endpoint Security Firewall
  • McAfee® Endpoint Security Web Control
  • McAfee® Endpoint Security Adaptive Threat Protection (ATP)Requires Threat Prevention

Endpoint Security includes these additional components:

  • McAfee® Endpoint Security Platform — Installed on the McAfee ePO server and the endpoint before Threat Prevention, Firewall, or SiteAdvisor Enterprise (previously named the Common module).
  • McAfee® Threat Detection Reporting — Installed on the McAfee ePO server for use with Adaptive Threat Protection.

On McAfee ePO, you can find the McAfee Endpoint Security 10.7.x extensions and packages in this bundle.

Bundle name Details
McAfee Endpoint Security + ATP
  • Endpoint Security Platform
  • Threat Prevention
  • Firewall
  • SiteAdvisor Enterprise
  • Adaptive Threat Protection
  • Client Proxy

To install McAfee Endpoint Security manually on McAfee ePO, download these extensions and packages as required from the Download portal.

Product name Extensions Packages
McAfee Endpoint Security
  • Endpoint_Security_Platform_Version_extension.zip
  • Firewall_Version_extension.zip
  • Threat_Prevention_Version_extension.zip
  • Web_Control_Version_extension.zip
  • Adaptive_Threat_Protection_Version_extension.zip
  • Threat_Detection_Reporting_Version_extension.zip
  • Endpoint_Security_Platform_Version_client.zip
  • Firewall_Version_client.zip
  • Threat_Prevention_Version_client.zip
  • Web_Control_Version_client.zip
  • Adaptive_Threat_Protection_Version_client.zip

For self-managed environment, you can download the standalone installer from the Download portal.

Product name Installer
McAfee Endpoint Security

McAfee_Endpoint_Security_Version_standalone_client_install

For optimal performance and protection, install the same version of the Endpoint Security modules.