About this release

This document contains important information about the current release. We recommend that you read the whole document.

CAUTION: We do not support the automatic upgrade of a pre-release software version. To upgrade to a production release of the software, you must first uninstall the existing version.

Included modules

This release includes these modules:

  • McAfee Client Proxy client software for Windows (build 2.3.2.251)
  • McAfee Client Proxy client software for OS X or macOS (build 2.3.2.111)
  • McAfee Client Proxy manager (build 2.3.2.251)
  • McAfee Client Proxy Help extension (build 2.3.2.010)
  • McAfee® Common Catalog coreCatalog (build 2.0.0.190)
  • McAfee Common Catalog catalogFramework (build 2.0.0.190)

McAfee® ePolicy Orchestrator® (McAfee® ePO™) modules for each product are included in the installation executable file.

Supported versions of McAfee ePO

The Client Proxy manager is compatible with these versions of McAfee ePO:

  • McAfee ePO 5.1.3
  • McAfee ePO 5.3.0
  • McAfee ePO 5.3.1
  • McAfee ePO 5.3.2
  • McAfee ePO 5.9.0
  • McAfee ePO 5.9.1

Supported operating systems for endpoints

The Client Proxy client software supports the following operating systems:

  • Windows Server 2008 R2
  • Windows Server 2012
  • Windows Server 2012 R2
  • Windows Server 2016
  • Windows 7
  • Windows 8 (Not including Windows 8 RT (Run Time) edition)
  • Windows 8.1 Update 1
  • Windows 10
  • Windows 10 Anniversary Update
  • Windows 10 RS2
  • Windows 10 RS3
  • OS X 10.10 (Yosemite)
  • OS X 10.11 (El Capitan)
  • macOS 10.12 (Sierra)

Compatible versions of McAfee Agent

Client Proxy 2.3.2 client software is compatible with these versions of McAfee Agent when deployed to endpoint computers running Windows or OS X or macOS.

Client Proxy client software McAfee Agent
For Windows 5.0.1–5.0.6
For OS X or macOS 5.0.4.449–5.0.6

Requirements for upgrading to OS X 10.10 or 10.11

Before upgrading to OS X 10.10 or 10.11, verify that you are using one of the following versions of McAfee Agent. Earlier versions fail to start on Mac computers running OS X 10.10 or 10.11. For more information, see McAfee KnowledgeBase article KB82993.

OS X version McAfee Agent versions required
OS X 10.10 5.0.4.449 for Mac Patch 2 HF972377 or later
OS X 10.11 5.0.4.449 for Mac or later